This was traced to an outage at the AWS data center in the CA Central region which experienced power and network issues. Once services were restored by AWS, work to restore our own services has restored all services.
Posted Aug 12, 2025 - 13:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2025 - 11:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 12, 2025 - 09:51 UTC
Investigating
We are currently investigating an issue with services in the CA region
Posted Aug 12, 2025 - 09:41 UTC
This incident affected: Talis Aspire Reading Lists (General), Talis Aspire Copyright Clearance (General), and Talis Elevate (General).