Lean Library is now available in the Firefox store, meaning new users can now install Firefox immediately. Lean Library Workspace functionality is also now available in the Firefox extension. Users with older versions of the extension should also update to the most up-to-date version as soon as possible.
Posted Jul 21, 2025 - 11:13 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 21, 2025 - 11:11 UTC
Update
Lean Library is now available in the Firefox store, meaning new users can now install Firefox immediately. Lean Library Workspace functionality is also now available in the Firefox extension. Users with older versions of the extension should also update to the most up-to-date version as soon as possible.
Posted Jul 21, 2025 - 11:10 UTC
Monitoring
Lean Library is now available in the Firefox store, meaning new users can now install Firefox immediately. Users with older versions of the extension should also update to the most up-to-date version as soon as possible.
Posted Jul 16, 2025 - 16:45 UTC
This incident affected: Lean Library (Lean Library Extension).