LEAN LIBRARY: Firefox extension is not available to download

Incident Report for Technology from SAGE

Resolved

This incident has been resolved.
Posted Mar 07, 2023 - 19:17 UTC

Monitoring

We have submitted the latest extension to Firefox. We are waiting for Firefox to review, once the review process is completed, the extension will be available to download again.

This issue should not affect current Firefox users.
Posted Mar 03, 2023 - 12:08 UTC
This incident affected: Lean Library (Lean Library).