We will be undergoing scheduled maintenance during this time.
Posted Jun 25, 2025 - 14:22 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 25, 2025 - 14:20 UTC
Scheduled
Crossref are carrying out maintenance that will impact our ability to lookup records for bookmarking in Talis Aspire. This outage is expected to last up to 24hours. Please use the Crossref status page to track the status of their maintenance - https://status.crossref.org/
Posted Jun 25, 2025 - 14:19 UTC
This scheduled maintenance affects: Talis Aspire Reading Lists (General).