Issue with access to some textbooks for Sage Catalyst customers
Incident Report for Technology from SAGE
Resolved
This incident has been resolved.
Posted Jul 29, 2024 - 13:01 UTC
Investigating
We are currently investigating this issue.
Posted Jul 29, 2024 - 12:47 UTC
This incident affected: Talis Elevate (Player).